Does the SQL language hint not work on this site (perhaps because it is in beta)? I tried adding <!-- language: sql --> to a question, as per the meta information on language hints, but it didn’t change the formatting at all. Am I missing something?

share
    
Here's a more recent example of syntax highlighting inaction. –  Nick Chammas Sep 22 '11 at 18:46
    
related request for a global setting here –  Jack Douglas Aug 26 '12 at 17:41
add comment

1 Answer

up vote 5 down vote accepted

I have added default style selections to a few of the tags that had no selection before. Let me know if there are others that appear to need styling.

Styling was added to the following tags:

Moderators do have the ability to change the default lang for highlighting per tag - just visit the tag info page:

http://dba.stackexchange.com/tags/sql/info


tag info language selector

share
    
Well when we added the manual hint it did not work. What more needs to be done specifically? –  jcolebrand Sep 28 '11 at 23:27
    
@jcole as Geoff said, you need to click through on the tag info link and look for this text Code Language (used for syntax highlighting): [list of languages] [save] –  Jeff Atwood Sep 28 '11 at 23:37
    
So it turns out the reason it never worked initially was because it wasn't turned on per-site when this site asked for it (got overlooked), nor is it turned on by default per-site at launch. –  jcolebrand Sep 29 '11 at 2:16
    
My last answer shows syntax highlighting just the way I would expect and hope - ie nearly right :-) Thanks for the update. –  Jack Douglas Sep 29 '11 at 9:52
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .